Express CMS performance degraded
Incident Report for Pugpig
Resolved
We have identified the root cause of this problem. Some of our clients use a third party plugin called Advanced Taxonomy Term Order. This is a popular plugin - we have a licence for it. However, we've learned that the plugin does a licence check with the servers at http://www.nsp-code.com/ - which are currently down, and this was blocking/slowing down requests.

We have put in a workaround to stop this check, and are looking into a permanent fix to ensure this cannot happen again.
Posted Jun 09, 2023 - 09:07 UTC
Monitoring
We have identified a slow component and have increased capacity. Services should be returning to normal. This component only affected a small number of customers with a specific kind of custom importer.

We are continuing to monitor.
Posted Jun 09, 2023 - 08:25 UTC
Investigating
We are currently investigating this issue.
Posted Jun 09, 2023 - 07:32 UTC
This incident affected: Pugpig Express (Express CMS Access, Express CMS Features, Express RSS Ingestion).